V2 firmware upgrade not working


I’ve been following your instructions for the lab board upgrade to firmware v 2.0.

Unfortunately i can’t get the upgrade to work.

Following the process in you guide all appears to work.

All works fine up to item 9.
9. Wait for green LED to turn on and LabBoard to display CALIb run.

Calib run does not display. I get ‘888888888’ displayed for a few seconds then the unit goes back to normal operation.

I tried to get into the menu system that is installed with version 2.0 but the instructions don’t say how to get into the menu. They just say, ‘from the menu’ but not how to get into menu mode.

I have followed the instructions 6 times now and have had the same result each time.

Can someone help me?

Ive tried pressing two of the select buttons at the same time and i get the following alternating displays:

ppp bac cal
1.02 bac cal

I’ve solved the problem.

The guide to firmware update step 1 says:

Click button to download latest firmware update file.

This downloads version 1.2 firmware, not the latest version.

I downloaded the latest version from the revision notes and it uploaded all ok.

Hello, thank you for your observations.

Can you confirm, that this link downloads 1.02 firmware?

With this definition inside?

#define VERSION "1.02"