Totemduino not recognized on PC with W10-64

I’m a newbie of the Arrduino world and I just bought a Totemduino. When I tried to connect it to my desktop PC running w10-64 it is not recognized : I went to the forum and I saw a discussion on COM ports not recognized on some PCs. The soluion - according to one of the members of the forum - is explained in a site www.ifamily/, but when i tried to open this lin,k my Malwarebytes blocked it.I tried also on another PC without Malwarebytes but I was not able to reach this site. So, at the present moment, I do not know why on my desktop PC Totemduino is not workinbg and on my old laptop on the contrary it is working.
By the way, the same situation happened with an original Arduino Uno and Nano 33, both worging on laptop but not on desktop with the same OS.
Would someone suggets any explanation and a solution ?
Thanks in advance

Hi, is error “This Device cannot start (Code 10)” displayed in Device Manager?

Try this tutorial:
Only perform “Install driver” at the moment. Ignore “Windows 11” and following steps.

thx for your help.
No, the message simply said that the drivers were not found and when I tried to install them they turned out to be NOT available.
I followed your suggestion but I got an error message
avrdude: ser_open(): can’t open device “\.\COM3”: Accesso negato. ( that means Access denied).
Thuis is the message that I got on desktop PC also with an official Arduino Uno and an official Nano 33.
I think that the problem could be in W10 that does not allow to connect to a USB device that is considered may be dangerous.
When I try to use Arduino IDE as an Administrator sometimes it uploads the sketch but I’m not able to open the serial monitor.
It looks like a problem with the USB management but I’m really not able to fix it.
With may old laptop that runs the same OS with the same updates it works.
Thx for your help.

Could you open “Device Manager” application ( devmgmt.msc ), “expand Ports (COM & LPT)” and take a screenshot (Win + Shift + S) ? This will give some more information.
TotemDuino should be connected.

sorry for my long delay in answering your request but I was out of town for emergency work.
However, I have verified which was the situation of the connection as depicted in W 10 device management

  1. in the laptop computer where I was able to install and connect without any problem both Totemduino and original Arduino Uno and Nano33 IOT
  2. in the desktop where I was not able to connect both Totemduino and original Uno and Nano 33
    I’m enclosing the pictures of the two screenshots
  3. gestione_dispositivi_PC_portatile|461x334 ( this is from the laptop where everything works);
  4. gestione_dispositivi-desktop ( this fromthe desktop where nothing works).
    I think that the problem could be related to the fact that in the desktop imore devices seem to be connected to the same hub/controller but this doesn’t seem to be the case in the laptop, but this is just an opinion of a newbie.
    Could you help me, please, to solve this problem?
    Thanks for your help

Change “View” to “Devices by type”.

There should be “Ports” (Porti) listing. When you connect TotemDuino to PC - a new device will show up here.
If everything is correct - “Prolific USB-to-Serial Comm Port” displayed.
If something wrong - error or unrecognized device is displayed.
Either way - COM port should be assigned. What is displayed here when TotemDuino is connected?

In case nothing is happening - select “Show hidden devices” and take a picture what is displayed in the Ports list. There should be some grayed out items (means they are not connected).
Or maybe there are other unknown devices with yellow exclamation mark?

I used the view"Devices by connection" because I thought that it could be useful to unferstand where the problem could be.
In fact, when because when I use the view “Devices by type” it just says that

  1. the device(Prolific USB-to-Serial Comm Port) is connected to COM3 and
  2. is working properly,
    while, on the contrary, when I try to upload even a very simple sketch ( such as Blink) I get the usual error message
    avrdude:ser-open(): can’t open device “\.\COM3”: Accesso negato (Denied Access)
    I’ve tried to ckeck the situation with Cool Term and it says that the COM3 is Disconnected
    I’m enclosing the screen shots from device manager

So I’m really perplexed and…blocked (at least on the desktop while, as I already said, the old laptop with the same OS works fine).
Could this problem be related to the fact that on the desktop all the USB ports are 3.0 or 3.1 ?

Could this problem be related to the fact that on the desktop all the USB ports are 3.0 or 3.1

No. USB 2.0 devices are compatible with 3.0 ports.

Ok. Now I see the situation. Driver for TotemDuino is working fine, but some process in your computer is connected to COM3 port, that is why Arduino tells “Access denied”. Also a bit suspicious - your Bluetooth module is disabled. It’s common that Bluetooth creates “COM3” port. Maybe some driver or process thinks, that Bluetooth is enabled and connects automatically to this port (which is TotemDuino).

So I will list a few ways to try resolve this issue:

Restart computer

  • Simply restart computer and check if Arduino is able to upload code.

Reinstall TotemDuino

  1. On Prolific USB-to-Serial Comm Port (COM3) select Uninstall device. A window will appear. Click Uninstall button.
  2. Unplug TotemDuino from USB. Plug it again. It should appear back in Ports list.
  3. Try to upload code trough Arduino again.

Change COM port

  1. On Prolific USB-to-Serial Comm Port (COM3) select PropertiesPort SettingsAdvanced....
  2. In COM Port Number select new free port (not in use). Close windows by clicking OK button.
  3. Prolific USB-to-Serial Comm Port with new selected port should be displayed.
  4. Try to upload code using Arduino. In case still not working - try to restart PC.

If none of these helps - I will post one more tutorial to resolve issue, but “Change COM port” should do the job.

I’ve just ended trying all the steps you suggested ( enabled the Bluetooth module, restarted the computer, reinstalled the Totemduino, changed the COM port) but nothing worked.
I opened the BIOS and checked for the USB configuration: I found that the only option disabled is XHCI Hand-off and, if i choose “enabled” I get a message
“This is a workaround for OSes without XHCI hand-off support. The XHCI ownership change should be claimed by XHCI driver”
However from what I’ve read on the web this shouldn’t interfere with the USB in this case.
The strange fact is that whichever COM port I choose the error message is always "Access denied " as if something is blocking all the USB ports( that work without problems when I connect other devices such as scanner, printer, headphones, external drives, etc) and the same message appears when I try in Cool Term to connect the chosen COM port.
I also disconnected all the devices connected to USB ports just leaving the Logitech unifying device for wireless keyboard and mouse but I do not think that it is responsible for the problem because in another older desktop with the same OS I have the same device and Arduino works fine.
So at the present I’m blocked and I’m eagerly waiting for your tutorial and suggestions
In Arduino forum I’ve found that a lot of people have had problems similar to mine but the solutions suggested didn’t work for me.
THX in advance

Yes, “XHCI Hand-off” should be off.

Yeach, that’s a strange issue for sure. Haven’t seen anything like this.

Check antivirus

  • If you using any third-party security program (Kaspersky, Mcafee, Malwarebytes, etc…), try to disable them. There should be an option to temporary disable protection (with a lot of warnings). It used to be a common problem antivirus software blocks something, resulting in very weird issues.

Find who is using COM port

  1. Connect TotemDuino (make sure Arudino upload is still Access Denied).

  2. Download Process Explorer.

  3. Run procexp64.exe.

  4. Select FindFind Handle or DLL....

  5. Type serial inside input field and click “Search” button.

  6. Wait for search to complete (Search button will light up. Takes half a minute).

  7. Check if something similar found. If success - it will display process which is using COM port.

Also long shot:

  • Check if there is a Microsoft Serial BallPoint device under “Mouse” category in “Device Manager”.

Hi Arnas,
I suspended the activity of both Kaspersky antivirus and Malwarebytes but the Access denied ist sill there.
Then I downloaded and run Process explorer according to your suggestions and i searched for “serial” and I tried also “USB”. Here are the pictures

But I ‘m not able to understand wthat really they mean.
I’ must confess that, even if I try to think positive, this situation isbecoming a little frustrating.
I’m afraid that the problem is related to some update of W 10 that I regularly update.

One more thing.
I downloaded a demo version of Serial Port Monitor a sw that has a free-14-day trial and on the COM connected to Totemduino there is a constant traffic ( the refresh rate is set at 1 second) but I was not able to find any clear conflict. May be you, who are an expert, could try this software.
The last resort could be a Team videoconference or a Teamviewer control of my PC but I don’t know if you have time for these options.
Maybe it’s better that I ask some friend of mine who is aIT expert to come to drink a beer at my home and to check what is wrong with my desktop.
Anyway, thx
PS no, there is no Microsoft Serial BallPoint device under “Mouse ” category

I agree that this became more complicated than it should be. Unfortunately I also getting out of options and from there it’s only a guessing game. Probably not an expert enough :face_with_peeking_eye:

At least it was a good challenge and I believe you have advanced from a “newbie” level for sure :smiley:

What else comes into mind:

  • In your Process Explorer (first image), search hasn’t completed, because “Search” button is still greyed out. I believe it didn’t show anything else after you took a screenshot? Because needed to wait a bit for that “ProlificSerial” to pop out.

And the last thing to try would be completely reinstall Prolific driver, but given it also doesn’t work with original Arduino - I doubt it will help.

  1. Connect TotemDuino to a working PC and upload an empty sketch (to make sure it doesn’t send anything over Serial).
  2. Go to Control PanelUninstall a program and uninstall “Prolific” or “PL-2303 USB-to-Serial”, if it’s in there.
  3. In Device Manager select to “Show hidden devices” and uninstall all Prolific entries (also select checkbox to remove driver):

    Or even better - click that “Devices by driver” and click to remove driver specifically (check all the boxes):
  4. Restart PC. Windows will reinstall driver automatically.
  5. Then plug in TotemDuino and check if it’s properly recognized in Device Manager.
  6. Try to upload sketch from Arduino. If doesn’t work - change COM port number and try again.

At this point I would probably think about clean Windows reinstall, installing chipset drivers from manufacturer, BIOS update. But it’s also a guessing and not guarantee to work.
Probably a good opportunity for your IT friend to get some free beer.

Also share if you have manage to find out the issue! Would be interesting to find out.